entre Desarrolladores

Recibe ayuda de expertos

Registrate y pregunta

Es gratis y fácil

Recibe respuestas

Respuestas, votos y comentarios

Vota y selecciona respuestas

Recibe puntos, vota y da la solución

Pregunta

0voto

Problemas con estilo usando Bootstrap

Hola, tengo este problema que la verdad no se por donde solucionarlo ya que no le se mucho a los estilos.

Estoy usando las librerías de Bootstrap, en la imagen que les pongo, en el mismo explorador. se ve la diferencia de estilo.

La imagen de arriba es la pagina que ya publique por medio del ISS, en mi equipo.

la imagen de abajo es la del localhost, donde se esta depurando la pagina.

Se ve una diferencia de estilos, pero tambien de efectos. pero se me hace raro que se vea diferente.

Estoy usando el IE 11, alguienn que me ayude a saber que esta pasando.

Imagen

Gracias

2 Respuestas

3votos

Ra-Hulk Puntos1490

Gracias por sus Comentarios, estuve revisando, pero salia exactamente lo mismo.

Y buscando en Google, vi algo que me llamo la atención que decía "Vista Compatibilidad", le rebusque y encontré ente cachito de código que lo soluciono, lo metí en el web config.

  <system.webServer>
      <httpProtocol>
          <customHeaders>
              <clear />
              <add name="X-UA-Compatible" value="IE=edge" />
          </customHeaders>
      </httpProtocol>
  </system.webServer>

Ahora si ya se ve "Bonita" :) .

Aqui lo encontré

Saludos

0voto

Leonardo-Tadei comentado

Gracias por comaprtir la respuesta.

Me llama la atención la solución, porque le estás diciendo así a IE11 que funcione como un IE8. La compatibilidad es hacia atrás...

4votos

MitsuGami Puntos8010

Obviamente es un tema diferente, tan solo basta ver el border-radius para darse cuenta. No me cuadra que sea exactamente la misma página aspx. Comprueba que se estén cargando correctamente todos los estilos en IIS.

3votos

Leonardo-Tadei comentado

Comarto con @MitsuGami: en el servidor hay algún CSS o JS que no te está cargando, por diferencias en los nombres de las rutas (por ejemplo relativas vs absolutas).

Probá ver la página del servidor con Firefox y en la consola de depurado fijate que se estén cargando todos los archivos.

1voto

bl4z3r comentado

@MitsuGami esta en lo correcto. La mejor manera para verificar esto es abriendo el panel de desarrollo de IE11 apretando F12 y ver el log de errores. Lo mas seguro que no este cargando el js de bootstrap por que tu problema aparece a la hora de usar diálogos modales y esta característica funciona correctamente cuando esta se carga correctamente el js.

Por favor, accede o regístrate para responder a esta pregunta.

Otras Preguntas y Respuestas


Actividad Reciente

...

Bienvenido a entre Desarrolladores, donde puedes realizar preguntas y recibir respuestas de otros miembros de la comunidad.

Conecta