entre Desarrolladores

Recibe ayuda de expertos

Registrate y pregunta

Es gratis y fácil

Recibe respuestas

Respuestas, votos y comentarios

Vota y selecciona respuestas

Recibe puntos, vota y da la solución

Pregunta

1voto

Tengo un TextView en el archivo consejo.xml, en strings.xml donde tengo el texto para hacerlo de manera dinamica, he usado diferentes maneras de hacer saltos de lineas, <br><br>,
con formato html

<![CDATA[ primera linea.. <br>
segunda  linea<br> ]]>

etc.
en el archivo consejo.xml, en el apartado diseño, me salen perfectamente los saltos de linea, pero al iniciar la app
en el emulador no me reproduce los saltos de linea, ni en el AVD ni en dispositivo fisico. No entiendo donde estoy fallando a la hora de que reprodzca los saltos de linea en la app. gracias.

1 Respuesta

2votos

boyka87 Puntos210

Solucionado, escribí el texto en el archivo consejo.xml en el apartado código, usando \n ya que va entre "" , y le di a alt + enter, extraer, directamente lo importó a strings.xml y así al ejecutar la app si que me reproducía los saltos de línea.
es extraño que escribiendolo directamente en strings no funcionara..
estoy empezando de 0 y siento si la pregunta era un poco absurda, de todas formas, gracias por publicarla igualmente.

0voto

Peter comentado

Gracias por compartir la solución!

Por favor, accede o regístrate para responder a esta pregunta.

Otras Preguntas y Respuestas


...

Bienvenido a entre Desarrolladores, donde puedes realizar preguntas y recibir respuestas de otros miembros de la comunidad.

Conecta