entre Desarrolladores

Recibe ayuda de expertos

Registrate y pregunta

Es gratis y fácil

Recibe respuestas

Respuestas, votos y comentarios

Vota y selecciona respuestas

Recibe puntos, vota y da la solución

Pregunta

0voto

Problema con PDO PHP

Hola a todos, estoy tratando de implementar una conexion con PDO en PHP, en mi localhost funcionaba todo bien pero al momento de subirla al servidor ya no me funcionó, tengo la version 5.2.17, ya le agregue la libreria PDO_mysql.dll reinicie el servidor y no me funciona, eh leido que se necesita instalar el driver de mysql para PDO, pero no se si eso se refiere a la libreria :( por favor ayudenme, no se que me falta por hacer, desde ya muchisimas gracias por cualquier ayuda

Saludos

1voto

Leonardo-Tadei comentado

Hola @rach,

agregá a tu pregunta la salida de phpinfo() para ver qué es lo que está cargando...

0voto

rach comentado

Gracias por responder, en el servidor esta lo siguiente
servidor

y en localhost tengo lo siguiente cargado
https://photos.app.goo.gl/mq6bNhbsTLo7yveG3

ya cargue las librerias en el servidor y en el php.ini ya le puse la linea para llamarlas

phpini

y las librerias

https://photos.app.goo.gl/8cbEvP9MlpOiaeiy2

no se que pueda estar pasando ya reinicie el servidor y no se cargan, por favor alguna idea? saludos y muchas gracias

2 Respuestas

1voto

pedrourday Puntos2690

Hola @rach
Me parece que el problema es el control de acceso HTTP, o sea, CORS (Cross-Origin Resource Sharing). Estando en localhost todo funciona OK, pero cuando el dominio es "cruzado", se te restringe el acceso por razones de seguridad.
Probá agregar la siguiente línea de código al principio:

<?php
   header("Access-Control-Allow-Origin: *");
?>

Saludos!

1voto

carlossevi comentado

CORS puede afectar a la relación entre navegador y servidor para determinar si es seguro permitir una petición de origen cruzado. Si de verdad tiene un problema con PHP y PDO, esa parte "no sale del servidor".

1voto

Leonardo-Tadei Puntos226490

Hola @rach,

según el phpinfo() del servidor, el soporte para MySQL vía PDO no está instalado.

Parece un servidor MS Windows. En estos servidores, si no conseguís los DLL de las bibliotecas de la MISMA versión del PHP que estás corriendo, los DLL no cargarán.

Deberías ver en los mensajes de arranque del servidor si algún módulo no carga.

También puede ser que estés poniendo los DLL en un directorio distinto al que usa el PHP en ejecución. En el phpinfo() también está esta información.

Hasta que no veas en phpinfo() que están cargados los módulos para PDO y MySQL, no funcionará la aplicación...

Saludos cordiales!

Por favor, accede o regístrate para responder a esta pregunta.

¿Conoces alguien que puede responder?
¡Comparte esta pregunta!


Otras Preguntas y Respuestas


Actividad Reciente

  • Freda0370183 ganó una medalla hace 7 horas

    Club de los 100 - Recibió un total de 100 puntos
  • NilaPilgrim4 ganó una medalla hace 15 horas

    Humano Verificado - Verificó su email
  • ErwinImhoff1 ganó una medalla hace 1 día

    Club de los 100 - Recibió un total de 100 puntos
  • FelipeMedel ganó una medalla hace 1 día

    Buen Comentario - Comment received +2 upvote
  • FelipeMedel ganó una medalla hace 1 día

    Renovador - Recibió medalla Buena Respuesta en res…
  • FelipeMedel ganó una medalla hace 1 día

    Buena Respuesta - Recibió +1 votos en respuesta
  • FelipeMedel ganó una medalla hace 1 día

    Buen Comentario - Comment received +2 upvote
  • FelipeMedel ganó una medalla hace 1 día

    Buena Respuesta - Recibió +1 votos en respuesta
  • EllPanda ganó una medalla hace 1 día

    Veterano - Primera visita hace más de 180 días
  • EllPanda ganó una medalla hace 1 día

    Regular - Primera visita hace más de 90 días
...

Bienvenido a entre Desarrolladores, donde puedes realizar preguntas y recibir respuestas de otros miembros de la comunidad.

Conecta