entre Desarrolladores

Recibe ayuda de expertos

Registrate y pregunta

Es gratis y fácil

Recibe respuestas

Respuestas, votos y comentarios

Vota y selecciona respuestas

Recibe puntos, vota y da la solución

Pregunta

1voto

Duda en utilización del framework CodeIgniter v2.2 o v3

Buenos Días colegas, aún no termino el sitio web que estoy desarrollando y resulta que estoy utilizando el framework CodeIgniter en su version 2.2 pero ya liberaron la versión 3 entonces tengo la inquietud por la cual realizo la pregunta presente, de que me aconsejan, continuar como voy o cambiar para mi proyecto para la versión 3 del framework.
Saludos Dairon

1 Respuesta

3votos

Leonardo-Tadei Puntos216110

Dairón,

lo ideal es trabajar siempre con la última versión estable de las herrameintas: de esta forma se consigue una mayor vida útil del software, ya que al usar herramientas de terceros, tocará actualziarlo cuando la versión actual se discontinue por el fabricante, para no tener problemas de seguridad.

Esta situación ideal debe por otra parte contrastarse con lo avanzado que esté el proyecto, la duración del proyecto y el costo de cambiar un framework por otro.

  • Si el proyecto está muy avanzado, no suele valer el esfuerzo en migrarlo, respecto a demorar la puesta en producción.
  • Si la duración del proyecto es mayor que lo que tarda el framework en sacar una nueva versión, nunca podrás alcanzarlo y en el mejor de los casos, saldrás a producción con una versión anterior. Si te pasa esto, elegiste mal la herramienta.
  • Si la actualización del framework no implica cambios en el código actual o son mínimos y bien acotados, no hay motivo para no entregar el producto con la última versión. Esto depende bastante tanto de la madurez del framework como de la forma en que se usa a nivel de los puntos de dependencia entre tu software y el framework.

En resumen, la evaluación para decidir debe establecer la relación costo-beneficio del cambio.

Saludos cordiales!

PD: A veces es mejor seguir como se está y usar la nueva versión para el próximo proyecto, porque la evaluación puede no ser tan simple.

dairon comentado Mar 30, 2015

Maestro también tengo la cuestion de que el sitio me lo van a permutar una vez este terminado para un hosting con php 5.4 donde el codeigniter 2.2 me da unos errores, voy a comenzar la migración ahora mismo para comenzar la implementación de api rest también saludos y gracias.
encontré estos link que me indican como migrar:
Migrar aplicación Codeigniter 2.x a 3.x
Upgrading from 2.2.1 to 3.0.0
Saludos Cordiales Dairon

Por favor, accede o regístrate para responder a esta pregunta.

¿Conoces alguien que puede responder?
¡Comparte esta pregunta!


Otras Preguntas y Respuestas


Actividad Reciente

...

Bienvenido a entre Desarrolladores, donde puedes realizar preguntas y recibir respuestas de otros miembros de la comunidad.

Conecta